Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

strange behavior from Analysis service Expand / Collapse
Author
Message
Posted Tuesday, September 10, 2013 11:02 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Thursday, February 20, 2014 9:25 AM
Points: 41, Visits: 124
Hi all,
so I am new to the company and working on this package that builds cubes.
SQL Job constantly fails with Executed as user: (user name). The step failed.

opened actual package and was able to drill down to tasks where it fails Analysis Services processing tasks that processes dimensions.

so If i run the single task it fails with unhanded exception error (no details)
but, if I restart Analysis services first and then run tasks in completed fine.
After, I initiate second task, fails with same error, restart services, works fine. and so on.
One more thing, if i try to backup OLAP db before restart I am getting same error (unhanded exception), it disappears after restart and reappears after each failed task.

Please suggest something. I am not too familiar with redeployment option. Maybe?

Thank you in advance
Post #1493291
Posted Wednesday, September 11, 2013 4:43 AM
SSC Veteran

SSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC Veteran

Group: General Forum Members
Last Login: 2 days ago @ 3:43 PM
Points: 234, Visits: 2,614
This is an off the wall suggestion, but does the server have enought memory? Also, it would be nice to see the entire text of the error.
Post #1493567
Posted Wednesday, September 11, 2013 9:10 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Thursday, February 20, 2014 9:25 AM
Points: 41, Visits: 124
64-bit, 32GB RAM

The error is in SQL Job history and I understand its meaningless. Also, it shows in job history with Exclamation point, not the red cross. When i expand, I can see 3 steps, second one shows failed

Message
Executed as user: domain\User. The step failed.

and this is from the log:
Started: 7:26:28 PM
Error: 2013-09-07 19:29:42.43
Code: 0xC020824E
Source: DFT Load DimAccount PreMerge Lookup stage_AccountParcelAddressMap to get APN [6279]
Description: OLE DB error occurred while populating internal cache. Check SQLCommand and SqlCommandParam properties.
End Error
Error: 2013-09-07 19:29:42.50
Code: 0xC004701A
Source: DFT Load DimAccount PreMerge SSIS.Pipeline
Description: component "Lookup stage_AccountParcelAddressMap to get APN" (6279) failed the pre-execute phase and returned error code 0xC020824E.
End Error
DTExec: The package execution returned DTSER_FAILURE (1).
Started: 7:26:28 PM
Finished: 7:29:52 PM
Elapsed: 204.143 seconds
Microsoft (R) SQL Server Execute Package Utility
Version 10.50.2500.0 for 32-bit
Copyright (C) Microsoft Corporation 2010. All rights reserved.

Thank you very much for you reply
Post #1493755
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse