Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Transactional replication - can't create publication Expand / Collapse
Author
Message
Posted Wednesday, August 28, 2013 6:41 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Sunday, July 13, 2014 11:14 PM
Points: 9, Visits: 174
Hi all,

I have a newly created Windows 2008R2 (64bit) server with MSSQL 2012 standard edition installed, acting as it's own distributor.

I have just gone to create the first publication on this particular server and I am getting an error with the snapshot agent.
"A .NET Framework error occurred during execution of user-defined routine or aggregate "sp_scriptdropinsreconciliationproc_sqlclr":"
I can be pretty sure it has nothing to do with the subscription, because I didn't even get to that stage.

I have done some browsing and all that I can find is something about a known problem after applying the .Net update KB2840628...
the only problem is my server has not had the update applied.

Any help would be greatly appreciated.
David
Post #1489485
Posted Friday, August 30, 2013 10:46 AM
SSChasing Mays

SSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing Mays

Group: General Forum Members
Last Login: Monday, July 21, 2014 11:33 AM
Points: 609, Visits: 425
Run the below and paste the results .

Select * from sys.dm_clr_loaded_assemblies

select * from sys.dm_clr_task

Most of the CLR issues causes due to memory spike, .net DLLs supporting SQL to run are currupted.

The immediate solution will be restarting the SQL services.
Post #1490231
Posted Friday, August 30, 2013 11:10 AM
SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: Friday, July 18, 2014 7:48 AM
Points: 416, Visits: 1,397
This occurred for us due to Windows Updates. A specific .NET update caused our replication and SharePoint systems to break. Uninstalling the update fixed it immediately.

The update that caused this issue in our case was KB2840628
Post #1490239
Posted Sunday, September 1, 2013 3:22 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Sunday, July 13, 2014 11:14 PM
Points: 9, Visits: 174
Hi sqldba725 and david.bianco

thank you both for your replies. I have fixed the problem... well I will say so far so good.

One of the possible cause I found on the internet was windows update KB2840628, the only problem was I did not have it installed.

Anyway to cut a long story short, I cloned the VM's involved and ran ALL the Windows updates to do with .Net Framework... tested and replication now works. I will spend some time of the next couple of days testing/reviewing before changing the actual production VM's. "fingers crossed"

Thanks for the replies greatly appreciated.
Post #1490486
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse