Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Bcp in Import Errors Expand / Collapse
Author
Message
Posted Thursday, June 20, 2013 2:59 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Saturday, October 26, 2013 8:43 AM
Points: 1, Visits: 124
Hi,
I am trying to run an Bcp import routine but get an issue on certain tables that are referenced within an Indexed View. I've tried setting the "ARITHABORT ON" and also enabled "QUOTED_IDENTIFIER" on both the table and database but still no joy. I get the error when running the command both through the command prompt and also through management studio. In both cases I get exactly the same error.

The command I run through command prompt looks as follows
bcp "databasename.[dbo].tablename" in C:\temp\bcp_outputTable.txt -S servername\instancename -T -c

The Output is below:
Starting copy...
1000 rows sent to SQL Server. Total sent: 1000
1000 rows sent to SQL Server. Total sent: 2000
SQLState = 37000, NativeError = 1934
Error = [Microsoft][SQL Server Native Client 10.0][SQL Server]INSERT failed beca
use the following SET options have incorrect settings: 'QUOTED_IDENTIFIER'. Veri
fy that SET options are correct for use with indexed views and/or indexes on com
puted columns and/or filtered indexes and/or query notifications and/or XML data
type methods and/or spatial index operations.

BCP copy in failed

Please bear in mind that this exact same command works perfectly for other tables that do not have the Indexed views referencing it. I have also tried the added -q command but then I get authentication issues even when adding proper sql username and pwd details.
Any help would be appreciated.
Thanks.
Post #1465953
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse