Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase 12»»

Pre Login HAndShake Error in Sql Server - 2005 SSMS Expand / Collapse
Author
Message
Posted Wednesday, May 22, 2013 2:33 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, May 21, 2014 3:28 PM
Points: 182, Visits: 650
Error:
A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: Shared Memory Provider error: 0 – No Process is on the other end of the pipe.) ((Microsoft SQL Server, Error: 233)

I tried to Force Protocol Encryption, checked other Network protocol settings but did't work.

Appreciate your help!


Thanks,
Post #1455706
Posted Wednesday, May 22, 2013 4:42 PM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: 2 days ago @ 4:52 PM
Points: 7,079, Visits: 12,569
From the provider error I am assuming you are trying to connect to a local instance. Please confirm.

Also, you posted in a 2008 forum but are saying 2005 SSMS. Please confirm the version of SSMS and the version of the server you're trying to connect to.

Are you trying to use a SQL Login or a Windows User to connect? If the former, make sure you have Mixed Mode Authentication enabled.


__________________________________________________________________________________________________
There are no special teachers of virtue, because virtue is taught by the whole community. --Plato
Post #1455753
Posted Wednesday, May 22, 2013 9:40 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, May 21, 2014 3:28 PM
Points: 182, Visits: 650
Thanks,

Sorry as I have posted in a 2008 forum but we have Sql Server 2005 and 2005 SSMS.
I have tried both Sql server and Windows.
I couldn't login so unable to check any other things except I have mentioned.

osql -L
==> Servers:
Local
MTDB

Servers:
— NONE –

>sqlcmd -L

Servers: MTDB

2) Enabled TCP/IP in SQL Server Configuration


3) All Firewall are off

4) Enable Remote Connection

5) SQL Server Browser Service is enabled

6) Created exception of sqlbrowser.exe in Firewall


7) No Alias!!!
Post #1455791
Posted Thursday, May 23, 2013 9:52 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: 2 days ago @ 4:52 PM
Points: 7,079, Visits: 12,569
osql was deprecated in SQL 2005 so I would recommend to stop using it. sqlcmd is the replacement for it.

Are you trying to connect to a local or remote instance? Try enabling Named Pipes too, just as a test, and then try connecting again.


__________________________________________________________________________________________________
There are no special teachers of virtue, because virtue is taught by the whole community. --Plato
Post #1456065
Posted Thursday, May 23, 2013 10:38 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, May 21, 2014 3:28 PM
Points: 182, Visits: 650
Thanks again.
I have already enabled - named pipes too, I was just checking osql -L and sqlcmd -L to see.

Post #1456094
Posted Thursday, May 23, 2013 3:29 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, May 21, 2014 3:28 PM
Points: 182, Visits: 650
Hi,
I am also using local instance which ones on VM.
I have also moved TCP before named pipes in the protocol order list.
When I am starting up Sql Agent from Sql Server Configuration manager, it's throwing an error:
The Request Failed or the Service Didn't respond in a timely manner, consult the event log.
I checked the Eventlog in Event Viewer and Sql Server Agent Error is: Sql Server Agent couldn't be started (reason: Unable to connect to Server local; Sql Server Agent can't Start)

I am also seeing other errors for Source - crypt32
Failed auto update retrieval of third party root list sequence number from www.download.windowupdate.com/msdownlod/update/v3/static/trustedr/authrootseq.txt> with error: This network connection does not exist.

Thanks
Post #1456234
Posted Monday, May 27, 2013 5:52 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, May 21, 2014 3:28 PM
Points: 182, Visits: 650
Hi,
I have tried many tips but none of the helping, any idea?
Post #1457159
Posted Monday, May 27, 2013 9:26 PM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: 2 days ago @ 4:52 PM
Points: 7,079, Visits: 12,569
Could be lots of things. Try some of the basic troubleshooting articles, see if you can narrow it down.

http://blogs.msdn.com/b/sql_protocols/archive/2008/04/30/steps-to-troubleshoot-connectivity-issues.aspx


__________________________________________________________________________________________________
There are no special teachers of virtue, because virtue is taught by the whole community. --Plato
Post #1457177
Posted Tuesday, May 28, 2013 11:20 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, May 21, 2014 3:28 PM
Points: 182, Visits: 650
It was security certificate issue, so it was fixed after renaming.

Thank for your help!

Post #1457454
Posted Tuesday, May 28, 2013 11:32 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: 2 days ago @ 4:52 PM
Points: 7,079, Visits: 12,569
Great news. There a lot of these connectivity issues but not a lot of solutions that detail renaming a security certificate. It might be extremely helpful to others that find this thread if you could detail exactly what you did to fix the issue.

__________________________________________________________________________________________________
There are no special teachers of virtue, because virtue is taught by the whole community. --Plato
Post #1457457
« Prev Topic | Next Topic »

Add to briefcase 12»»

Permissions Expand / Collapse