Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Deploying ssis package Expand / Collapse
Author
Message
Posted Monday, May 20, 2013 12:19 PM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Wednesday, October 16, 2013 8:31 PM
Points: 18, Visits: 117
Hi All,
Am trying to deploy a package. which is created in VS2010 into sql server 2012. but am getting below error while execution of the job.



Date
Log Job History (Abdc)

Step ID 1
Server Job Name ABCD
Step Name ABCD
Duration 00:00:01
Sql Severity 0
Sql Message ID 0
Operator Emailed
Operator Net sent
Operator Paged
Retries Attempted 0

Message
Executed as user: XYZ. Microsoft (R) SQL Server Execute Package Utility Version 11.0.2100.60 for 64-bit Copyright (C) Microsoft Corporation. All rights reserved. Started: Error: Code: 0xC00291CB Source: Send Mail Task Send Mail Task Description: Either the file "C:\Users\***\Desktop\&&&\ynmd.txt" does not exist or you do not have permissions to access the file. End Error Error: Code: 0xC0024107 Source: Send Mail Task Description: There were errors during task validation. End Error DTExec: The package execution returned DTSER_FAILURE (1). Started: Finished: Elapsed: 0.375 seconds. The package execution failed. The step failed.


when i execute it without sql job it executes but it is not working in sql job?

Thanks in Advance.
Post #1454675
Posted Wednesday, May 22, 2013 9:39 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Tuesday, August 12, 2014 4:51 PM
Points: 7,097, Visits: 12,597
Looks like a validation error. Is it safe to assume that any paths to the attachment file are determined dynamically at runtime? Many times the problem with deploying to a server is that paths are different from the machine where the Packagewas developed.

Try setting the DelayValidation property on your file connection manager to true and redeploying the package before trying again. If that does not correct the issue you may also try setting the property to true on the Send Mail Task as well.


__________________________________________________________________________________________________
There are no special teachers of virtue, because virtue is taught by the whole community. --Plato
Post #1455583
Posted Thursday, May 23, 2013 7:34 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Friday, August 15, 2014 6:44 AM
Points: 132, Visits: 246
In addition to opc.three's comments, you probably also need to configure a SQL Server proxy to run your SSIS package using a job. That proxy account will also need permissions to whatever files/folders your package will access.

Also the path to the problem file indicates it is sitting in some User's Desktop - a pretty unlikely location for external files on a production system. I would suggest also looking at implementing package configurations.


____________
Just my $0.02 from over here in the cheap seats of the peanut gallery - please adjust for inflation and/or your local currency.
Post #1456004
Posted Thursday, May 23, 2013 8:31 AM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Wednesday, October 16, 2013 8:31 PM
Points: 18, Visits: 117
I will Try on That!!
Post #1456034
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse