Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Data Driven subscription issue Expand / Collapse
Author
Message
Posted Tuesday, May 7, 2013 6:44 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Wednesday, December 4, 2013 2:36 AM
Points: 28, Visits: 78
Hello,

Can you please help me to solve following error for DD Subscription:

While running the subscription it shows the status on browser as Processing: 0 processed of 1 total; 0 errors.

Log details:
httpruntime!ReportManager_0-39!3fc8!05/07/2013-11:27:11:: e ERROR: Failed in BaseWorkerRequest::SendHttpResponse(bool), exception=System.AppDomainUnloadedException: Attempted to access an unloaded appdomain. (Exception from HRESULT: 0x80131014) at System.StubHelpers.StubHelpers.GetCOMHRExceptionObject(Int32 hr, IntPtr pFrame, Object pThis) at Microsoft.ReportingServices.HostingInterfaces.IRsHttpPipeline.SendResponse(Void* response, Boolean finalWrite, Boolean closeConn) at ReportingServicesHttpRuntime.BaseWorkerRequest.SendHttpResponse(Boolean finalFlush)
library!ReportManager_0-39!3fc8!05/07/2013-11:27:11:: e ERROR: Throwing microsoft.ReportingServices.Diagnostics.Utilities.ReportServerHttpRuntimeInternalException: RsWorkerRequest::FlushResponse.,Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerHttpRuntimeInternalException: An internal or system error occurred in the HTTP Runtime object for application domain ReportManager_MSSQLSERVER_0-39-130123889993312881. ---> System.AppDomainUnloadedException: Attempted to access an unloaded appdomain. (Exception from HRESULT: 0x80131014) at ReportingServicesHttpRuntime.BaseWorkerRequest.SendHttpResponse(Boolean finalFlush) at ReportingServicesHttpRuntime.RsWorkerRequest.FlushResponse(Boolean finalFlush)
--- End of inner exception stack trace ---;
library!WindowsService_24!14ec!05/07/2013-11:27:15:: i INFO: Initializing EnableExecutionLogging to 'True' as specified in
Server system properties.
emailextension!WindowsService_24!14ec!05/07/2013-11:27:15:: e ERROR: Error sending email. System.Runtime.InteropServices.COMException (0x80040213): The transport failed to connect to the server. at ReportingServicesCDOInterop.MessageClass.Send() at Microsoft.ReportingServices.EmailDeliveryProvider.EmailProvider.Deliver(Notification notification) notification!WindowsService_24!14ec!05/07/2013-11:27:15:: e ERROR: Error occured processing subscription cde3ed53-93fe-4080-8994-cf5b235ab67c: Failure sending mail: The transport failed to connect to the server.
Post #1450100
Posted Sunday, May 12, 2013 11:43 PM


SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: Today @ 8:28 AM
Points: 451, Visits: 844
What version of Reporting Services is this?

Do you have an SMTP server (or exchange) set up in the Reporting Services config utility on the server? Is it on a reachable part of the network?

Can you set up a non-data-driven subscription email that sends successfully? I.e. make a really basic report and schedule it to email to yourself and check the "Reporting Services" to "email server" part is working?

The error log is a bit misleading, the unloaded appdomain error is just a symptom of the real problem, I think the later part of the log is the important part, and it looks like Reporting Services can't connect to your mail server.
Post #1451975
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse