Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

SQL Server 2005 32-bit on Windows 2008 R2 x64 OS Expand / Collapse
Author
Message
Posted Monday, April 15, 2013 11:31 AM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Thursday, June 19, 2014 3:15 PM
Points: 11, Visits: 57
Before I get started, I'm well aware that this type of setup is bizarre and I definitely did not recommend. I work in a corporation where the application vendor demanded 32-bit SQL 2005 and now they are paying for their decision because the instance is only able to use 2GB of address space on a physical server that has 120GB of RAM. The instance is now constantly swapping pages of memory every 200 seconds.

This was one of many sql installs that we had to do for a large project on a strict deadline, so we didn't have as much time to look into this install. I had assumed the the Windows team and Application team had the correct server configuration when we did the install. I knew that the AWE switch was available for 32-bit SQL, but overlooked that we were installing on a x64 OS.

With that said, I've done some research and found that you can allow SQL to use up to 4GB RAM by setting the \LARGEADDRESSAWARE:YES flag. This makes sense because I've done this with video editing applications years back, but what I've not been able to find is where I set this flag for sql server. I've also read somewhere else that sql server already has the flag built into the application, so this search has gotten pretty confusing.

Is this an option that needs to be setup on the service as a startup parameter or is this a boot.ini configuration? I've researched both options and neither seem to be the answer for setting the \LARGEADDRESSAWARE:YES flag. I understand it's an odd setup so many of us SQL DBA's are going to have limited to no experience with this configuration, but I'm hoping someone out there can shed some light on this issue.
Post #1442424
Posted Monday, April 15, 2013 2:29 PM
SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Today @ 3:49 PM
Points: 5,971, Visits: 12,861
you can use AWE with 32bit SQL on a 64bit OS.

http://sqlblog.com/blogs/argenis_fernandez/archive/2012/12/30/the-myth-around-32-bit-sql-server-instances-on-64-bit-operating-systems-and-awe.aspx


---------------------------------------------------------------------

Post #1442495
Posted Tuesday, April 23, 2013 7:32 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Friday, June 27, 2014 5:59 AM
Points: 7,079, Visits: 12,567
Just in case, because the article is not very clear on this point, if you enable AWE in the SQL Server instance you should absolutely set max server memory using sp_configure:

EXEC sys.sp_configure 
@configname = 'max server memory (MB)',
@configvalue = ####; -- something sensible that leaves memory for the OS to operate
GO
RECONFIGURE;
GO



__________________________________________________________________________________________________
There are no special teachers of virtue, because virtue is taught by the whole community. --Plato
Post #1445418
Posted Tuesday, April 23, 2013 8:26 AM


Old Hand

Old HandOld HandOld HandOld HandOld HandOld HandOld HandOld Hand

Group: General Forum Members
Last Login: Friday, March 21, 2014 9:46 AM
Points: 387, Visits: 1,078
along with AWE, you have to use PAE in boot.ini to reveal physical ram more than 16gb.
Post #1445469
Posted Tuesday, April 23, 2013 11:20 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Friday, June 27, 2014 5:59 AM
Points: 7,079, Visits: 12,567
SQL Show (4/23/2013)
along with AWE, you have to use PAE in boot.ini to reveal physical ram more than 16gb.

PAE is not a valid boot.ini configuration on 64-bit OSes.


__________________________________________________________________________________________________
There are no special teachers of virtue, because virtue is taught by the whole community. --Plato
Post #1445595
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse