Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase 12»»

Publishing and accessing SQL Server 2008 Reports Expand / Collapse
Author
Message
Posted Sunday, March 31, 2013 7:20 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, August 15, 2013 3:23 PM
Points: 6, Visits: 21
I 'm new to SQL Server database and I need help. I 'm trying to publish sql reports for users to access from the web. We have SQL server 2008 database with data, and I have installed a separate SQL server 2008 with Reporting Services on my windows xp machine. I have created data source from the remote sql server 2008 installed on a Windows Server, and publish the reports. I can access the report manager through the URL (//localhost:8080/ReportServer) on my xp machine browser. However, when I typed the same URL from another computer, I get page cannot be displayed message.

What is going on? Does the report manager URL needs to be configured on the SQL Server that has the database instance? Please help. Thanks


To make myself clear, what I 'm trying to acomplish is to create and publish reports for users to access from their workstations. Any help will be appreciated.
Post #1437346
Posted Monday, April 1, 2013 2:41 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Yesterday @ 9:34 AM
Points: 6,518, Visits: 14,039
Where does your instance of ssrs look for its databases?
Are you deploying the reports via visual studio or importing via web manager URL?


-----------------------------------------------------------------------------------------------------------

"Ya can't make an omelette without breaking just a few eggs"
Post #1437380
Posted Monday, April 1, 2013 1:41 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, October 22, 2014 6:30 PM
Points: 191, Visits: 900
One thing to keep in mind is that SSRS report access is Windows Authentication only. This means that the users accessing the URL must have permissions on the server to get to those reports. One thing that really messed me up at the beginning, I could see the reports, but the users that were testing it couldn't get to it. Reason: All users must have access to the main landing page in SSRS. I, as local admin, had access to it, but they didn't since they weren't local admins. Make sure all users using the reports have access to the main page. Then, the best thing to do is to put the reports in individual folders (grouped by what they do, for instance), and set appropriate permissions for each of these folders, or even to the individual report. That way, everyone can get to the home page, but only if you have permissions to each folder can you click on it and have access to the reports in it.

Don't confuse this with "I am using a SQL username and password to get to my data". That is totally different. That is how the report actually gets to the data. The issue above is that the individual users that are going to be running the reports must have Windows access to those pages in SSRS to then get access to those reports. Keeping these two things in mind should help greatly.

One way to accomplish the Windows authentication to the reports and directories is to set up local groups on the SSRS server. Then add Domain users to each of the desired groups. Then give those groups access to the directories and/or individual reports. This makes it as easy as adding a user to a local box group to give someone new access to the reports they need. A normal sysadmin could do this, and wouldn't have to know how SSRS is set up.

It is explained in detail below. Hope all this helps.



How to use Local Groups to frame the SSRS permissions



If on Server 2003, do a right-click on My Computer and choose Manage. Under System Tools, expand Local Users and Groups.

On Server 2008, go to Server Manager, and expand Configuration on the left side, and expand Local Users and Groups.

Create a new local Group (right-click Groups and choose New Group), something like SalesReportUsers, and add Windows users to it that are ok to run the reports. You can also add another group called SalesReportMakers, and add Windows users to it that you will allow to actually create and install reports.

Also, create a group that will include ALL domain users, something like AllRptUsers.

Note that SSRS requires windows authentication for users who run or create reports (the actual reports can use Windows or SQL Server authentication for the data retrieval).

Then, in the SSRS administration screens, set the permissions for each directory and/or specific report for the local group that should have access to those reports, or creation permissions.

Important - Make sure to give the AllRptUsers local group access to the SSRS home page. That way, all users can see the directories, but only the ones that have access to those directories can actually choose them and see what is in them (once those permissions are set as well). If this is not done, nobody will be able to get to the SSRS website, since no one will have access to the home page.

Then, as new users need to be added, just figure out what groups they should belong to and add them in the Local Groups as Windows users. The SSRS permissions are already set for those groups (assuming you did so above), so no further action would be needed.
Post #1437591
Posted Monday, April 1, 2013 1:43 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, October 22, 2014 6:30 PM
Points: 191, Visits: 900
Just to clarify:

This means that the users accessing the URL must have permissions on the server


This means that they have URL access through SSRS permissions for the main page, not setting up permissions on the actual server. Sorry for any confusion.
Post #1437593
Posted Monday, April 1, 2013 2:03 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, August 15, 2013 3:23 PM
Points: 6, Visits: 21
Hi Viking,

I truly appreciate your help. I will follow you directions and I believe it will work. Thanks
Post #1437600
Posted Monday, April 1, 2013 2:27 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, October 22, 2014 6:30 PM
Points: 191, Visits: 900
Glad I could help. Please let us know how it works.
Post #1437608
Posted Monday, April 8, 2013 11:12 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, August 15, 2013 3:23 PM
Points: 6, Visits: 21
Hi Viking,

I have another issue, I can't see the contents and the properties tab in my Report Manager page. I could see almost everything else. I have login as local administrator. I 'm trying to assign roles to groups I have created. Please let me know what I 'm missing. Thanks
Post #1439950
Posted Monday, April 8, 2013 1:57 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, October 22, 2014 6:30 PM
Points: 191, Visits: 900
Confirm that you are at the proper website address.

User:
http://<servername>:80/ReportServer

Admin:
http://<servername>:80/Reports


Use the Admin one to set up permissions.

Do you see the "New Folder", "New Data Source", "Upload File" and "Report Builder" buttons on the tannish banner under where the Contents and Properties tabs should be? Along with the "Show Details" button on the far right side?

I always set myself this way, but perhaps you need to be an SA as far as your Windows Authenticated login goes. Are you set up with a windows login with it being a sysadmin? That may be needed if you are going through the Admin screen.

Try that and see if it changes it.
Otherwise, I am not knowing......
Post #1440013
Posted Monday, April 8, 2013 2:54 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, August 15, 2013 3:23 PM
Points: 6, Visits: 21
Viking,

I see the New Folder, New Data Source, Report Builder, Folder Settings and Upload File tabs on the home page. I login with Windows Account different from "SA" and can connect to the SQL Server and Reporting Services Configuration Manager with the Windows Authentication Account. This account has SQL Server admin and all the SQL server roles assigned to it. I have asked my network admin guy to create Windows authentication account "SA" with admin rights and I will try it and hope to see the Contents and the Properties tabs. Thank you very much
Post #1440028
Posted Tuesday, April 9, 2013 8:50 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, October 22, 2014 6:30 PM
Points: 191, Visits: 900
Creation of an actual account named SA is unnecessary. What I meant was to find out if your Windows Authenticated login to the database server was assigned sysadmin fixed server role permission.

If you have the sysadmin fixed server role and you are a local admin on the server, then I don't know right off the bat what the problem is. Hopefully a reporting guru can answer that question.

Sorry I couldn't be of more help.
Post #1440389
« Prev Topic | Next Topic »

Add to briefcase 12»»

Permissions Expand / Collapse