Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

datatype changes from DATE to INT in DRILLTHROUGH Expand / Collapse
Author
Message
Posted Wednesday, February 27, 2013 8:26 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, November 13, 2014 9:06 AM
Points: 5, Visits: 98
Hi Guys,

I'm adding a drillthrough action on my cube.
The measure displays in DATE on the field. I then created a drillthrough and added the measure to the drillthrough columns and when I perform the drill through action on excel it converts to INT.

2/14/2013 22:51 gets converted to 41319.95241

Am I missing any setting or property in the drillthrough?

Please help.

Thanks!
Post #1424856
Posted Wednesday, February 27, 2013 8:30 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, November 13, 2014 9:06 AM
Points: 5, Visits: 98
Also, when I view the cube in management studio and perform the drillthrough there, the data type doesn't change. Only when it is in excel.
Post #1424858
Posted Friday, March 1, 2013 9:56 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Monday, January 13, 2014 7:34 AM
Points: 117, Visits: 499
Pretty sure there isn't a setting to fix this in the cube - it sounds like Excel is auto-converting this not SSAS telling Excel that it's a number

The only thing I can think that you could do is have an attribute of the date that is a number (yyyymmdd) and include that on the drilldown rather than the long date

Mack
Post #1425603
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse