Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Can't Connect to SQL Server 2005 Expand / Collapse
Author
Message
Posted Tuesday, February 26, 2013 8:55 AM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Tuesday, September 24, 2013 5:00 PM
Points: 50, Visits: 161
I have a network with two Windows Server boxes. One is a 64bit machine and the other is a 32bit machine. I can ping the 32bit machine while on the 64bit machine and vice versa. My problem is if I'm on the 32bit machine I can't connect to SQL Server 2005 installed on the 64bit machine and vice versa. I have SQL Server 2005 64bit installed on the 64bit machine.

I have SQL Server Browser running on both machines and Windows Firewall turned off. Both are allowing remote connections. I disabled Named Pipes connection on both machines so only TCP/IP is enabled. I tried using SQL Server Authentication to connect to SQL Server but that didn't work either. This is the error I get

"
A network-related or instance-specific error occurred while establishing a connection to SQL Server.
The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections.
(provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 121)
"

I don't know what other troubleshooting should I perform in order to get these two SQL Server Installs to talk to each other. Any help is greatly appreciated.

Thanks
Post #1424124
Posted Wednesday, March 6, 2013 1:30 PM


SSCommitted

SSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommittedSSCommitted

Group: General Forum Members
Last Login: Yesterday @ 1:09 PM
Points: 1,715, Visits: 1,320
In the off chance the firewall is not completely off, you should add port 1433 to the Windows Firewall.

Have you verified that both SQL Servers "Allow remote connections to this server" is checked in the SQL Server Properties? If this is SQL 2005, this is off by default.


Chris Powell

George: You're kidding.
Elroy: Nope.
George: Then lie to me and say you're kidding.
Post #1427611
Posted Wednesday, March 6, 2013 2:36 PM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Tuesday, September 24, 2013 5:00 PM
Points: 50, Visits: 161
I did have that connection enabled and had no luck.

I was able to resolve this by

1) Going into SQL Server Configuration Manager
2) Go to Protocols for MSSQLSERVER (under SQL Server 2005 Network Configuration)
3) Right click on TCP/IP (make sure status = Enabled)
4) Go to IP Addresses tab
5) Make all IP Addresses Active (made sure that both server IPs are listed on there and are enable and active)

Don't know why i had to turn these IP Addresses on but it was the only way I got it to work since I tried other troubleshooting methods.
Post #1427640
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse