Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Integrating to SharePoint 2010 - blank page!! Expand / Collapse
Author
Message
Posted Wednesday, February 13, 2013 10:42 PM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Wednesday, April 23, 2014 12:39 AM
Points: 18, Visits: 98
Hi,

I am trying to integrate an ssrs2008 with sharepoint 2010. I did all steps like:
- change SSRS to Integrated mode
- join SSRS server to sharepoint farm
- install ssrs add-in in the sharepoint server
- Install WFE in ssrs server
and stock at the level I want to add ssrs server in the sharepoint central managment.

When I click the SSRS url it asks for the windows credential which is a good thing but when I enter the windows login and password it will not accept that and asking again and again for the windows login and after 4 - 5 times I'll face a blank page. I checked the log and it's says permission error!! As I am sure the windows login is OK and I can connect to other sharepoint websites with the same windows login what is missing here? I reckon the problem should be in SSRS server!!!

I should say when I again change SSRS back to the native mode it works fine! Any idea?

Many thanks,
Amir
Post #1419815
Posted Tuesday, March 5, 2013 7:53 PM


SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: Today @ 5:47 AM
Points: 472, Visits: 879
Sharepoint also lets you use "Report viewer" and "Report list" webparts directly in a page setup. I prefer these to using integrated mode because it is so much simpler. If you don't have them on your sharepoint you might need to install them from the sharepoint designer.

It lets you then embed a report directly in a sharepoint page by just giving the report part some settings such as the report manager URL and the report folder/name.

Permissions on the sharepoint page still apply, as well as permissions in SSRS report manager.
Post #1427127
Posted Tuesday, March 5, 2013 8:38 PM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Wednesday, April 23, 2014 12:39 AM
Points: 18, Visits: 98
Hi,

Thank you so much for the reply and great suggestion!

At last I found what was the issue with the blank page... It was mode of authentication which was set to Windows Negotiate instead of NTLM.

In Reporting Services Server, there is a config file “reportserver.xml” located in "\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\"


In this file there is a line specified authentication mode which for us was set to
• windows negotiate first priority
• NTLM second priority

To solve the issue I just removed windows negotiate!!!
Post #1427144
Posted Tuesday, March 5, 2013 9:12 PM


SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: Today @ 5:47 AM
Points: 472, Visits: 879
Good to know, thanks for letting us know how you fixed it , that will certainly help other people with a similar issue.



You would need to have Kerberos set up on your domain in order to use Negotiate, and it's a headache!
Post #1427152
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse