Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Login with SA acct failed Expand / Collapse
Author
Message
Posted Monday, January 07, 2013 5:46 PM
Old Hand

Old HandOld HandOld HandOld HandOld HandOld HandOld HandOld Hand

Group: General Forum Members
Last Login: Monday, February 24, 2014 1:04 PM
Points: 383, Visits: 2,351
Hi All,

Here is a scenario that I am going through and need your opinion on this.

One of the app guy is asking to login to their server with SA acct since the vendor is there to install an application.

We only built the server for them, we do not have access to the server....however, we created the SA acct(SQL Authentication) during the instllation.

Since I didn't have access to the server, I could not RDP to it....so, the guy shared the screen with me and gave me control and I tried to login with SA acct, however failed. This is SQL 2008, default instance. The error was related to some Shared memory, shared memory was enabled at the config mgr, don't remember the whole error now. I have a feeling that I am missing something here.

Anyway, I just want to touch base with you guy and see if I am doing this correctly. Did anyone went through similar situation? Is there any other way you can login with SA acct? Please advise.

Thanks,
SueTons.


Regards,
SQLisAwe5oMe.
Post #1403934
Posted Monday, January 07, 2013 7:36 PM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Tuesday, January 07, 2014 8:13 PM
Points: 47, Visits: 807
It would have been best if you posted the entire error message but by speculating what could be happening is that your SA account is usually in denied mode since the time of the installation has finished, you need to login as a local administrator who has access to the SQL Server instance with sysdba ..> this would have been done during installation.

Also check on the server properties if mixed authentication is allowed, you would never be able to login if this is not enabled.

Regards,
Post #1403945
Posted Monday, January 07, 2013 7:50 PM


Hall of Fame

Hall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of Fame

Group: General Forum Members
Last Login: Today @ 2:53 PM
Points: 3,733, Visits: 7,072
By default when installing SQL Server the built in administrators group is added into the sysadmin role, so as long as you/they can connect to the SQL Server instance with an account that's a local administrator on that machine, you should be able to troubleshoot appropriately i.e. (reset the sa password, etc)

As Superdoc mentioned, it would help if you could post the actual error (you can find this in the log file/sql error log file that's by default located in the directory...which is usually something like \MSSQL10.MSSQLSERVER\MSSQL\Log\)


______________________________________________________________________________
"Never argue with an idiot; They'll drag you down to their level and beat you with experience"
Post #1403948
Posted Tuesday, January 08, 2013 10:34 AM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: 2 days ago @ 9:25 AM
Points: 7,070, Visits: 12,523
MyDoggieJessie (1/7/2013)
By default when installing SQL Server the built in administrators group is added into the sysadmin role, so as long as you/they can connect to the SQL Server instance with an account that's a local administrator on that machine, you should be able to troubleshoot appropriately i.e. (reset the sa password, etc)

That used to be the case but is not done by default in SQL 2008 installers and above.


__________________________________________________________________________________________________
There are no special teachers of virtue, because virtue is taught by the whole community. --Plato

Believe you can and you're halfway there. --Theodore Roosevelt

Everything Should Be Made as Simple as Possible, But Not Simpler --Albert Einstein

The significant problems we face cannot be solved at the same level of thinking we were at when we created them. --Albert Einstein

1 apple is not exactly 1/8 of 8 apples. Because there are no absolutely identical apples. --Giordy
Post #1404374
Posted Tuesday, January 08, 2013 11:21 AM
Old Hand

Old HandOld HandOld HandOld HandOld HandOld HandOld HandOld Hand

Group: General Forum Members
Last Login: Monday, February 24, 2014 1:04 PM
Points: 383, Visits: 2,351
Hi All,

I just want to update you guys with the results.

I could not RDP directly to the server due to firewall issue.

So, there was a jump server(terminal server)....which I need to RDP to it first, then from there I RDP to the target server.....since my login has SA privilage, I was able to change the passwor for SA acct.

Anyway, thanks for all of your inputs.

SueTons.


Regards,
SQLisAwe5oMe.
Post #1404395
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse