Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

SSAS 2012 Actions not appearing in Excel 2010 Expand / Collapse
Author
Message
Posted Wednesday, November 28, 2012 4:48 AM
Say Hey Kid

Say Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey Kid

Group: General Forum Members
Last Login: Friday, October 17, 2014 6:34 AM
Points: 703, Visits: 2,182
Hi,

I have an SSAS cube that i want to add some actions to. I've had problems adding a reporting action to the cube so decided just to add a URL action instead. Start simple and build on the concepts...

So i add a new action, give it a name, set the Target Type to Cells, Taget object to All Cells. I've put no condition on the action since i want it to appear all the time.

The action content type is set to URL the action expression is set to "http://www.google.co.uk" I've also set a caption of "Google" under the additional properties and said that the caption is MDX (I'm aware that it isn't but i do intend to expand on this...).

See the attached screenshot.

I then build and deploy my cube, call up excel (2010) and then create a pivot table off the back of the cube but when i right-click the cells in the pivot table and go to "additional actions" it tells me that there are none specified.

Does anyone know where i'm going wrong? I'm obviously missing something rather fundamental here.

Thanks,

Simon




MCSA: SQL Server 2012
Follow me on Twitter: @WazzTheBadger
LinkedIn Profile: Simon Osborne


  Post Attachments 
Action.png (7 views, 36.65 KB)
Post #1389641
Posted Wednesday, November 28, 2012 5:06 AM
Say Hey Kid

Say Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey Kid

Group: General Forum Members
Last Login: Friday, October 17, 2014 6:34 AM
Points: 703, Visits: 2,182
Hi,

As an update to this. It seems that this action does work but not on pivot tables that have previously been created. If i create a new table then the action is available.

Even after doing a "refresh all" in Excel the action is not available on PivotTables that have previously been created. I'm going to investigate further but may well end up creating a connect item.

Thanks,

Simon




MCSA: SQL Server 2012
Follow me on Twitter: @WazzTheBadger
LinkedIn Profile: Simon Osborne
Post #1389649
Posted Thursday, November 29, 2012 1:00 AM
Say Hey Kid

Say Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey KidSay Hey Kid

Group: General Forum Members
Last Login: Friday, October 17, 2014 6:34 AM
Points: 703, Visits: 2,182
Hi,

As a further update to this... It turns out that the reason my actions were not appearing on my cells was because i had a filter on my excel report that was using a multi select. If in the filter i'd have selected ALL or just one of the list items then the action would have appeared.

This has been seen elsewhere and is blogged about here:

http://cwebbbi.wordpress.com/2009/10/26/actions-and-multiselect/

Anyhow, just thought i'd share my final findings because it took me several hours of fiddling and searching yesterday before finding out exactly what the problem was.

Thanks,


Simon




MCSA: SQL Server 2012
Follow me on Twitter: @WazzTheBadger
LinkedIn Profile: Simon Osborne
Post #1390324
Posted Saturday, March 2, 2013 8:41 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Yesterday @ 9:35 AM
Points: 1, Visits: 14
I had the issue when I changed the name of a dimension and forgot to changed it in the parameters defined for the report action.
Once i updated the typo, everyting was back to normal.
Post #1425861
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse