Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Getting login failed error when trying to run sql agent jobs after failback or failover Expand / Collapse
Author
Message
Posted Wednesday, September 26, 2012 9:04 AM
Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Friday, July 25, 2014 10:27 AM
Points: 1,319, Visits: 1,720
Hello All,

I am using SQL Server 2008 R2 SE. For HA I am using double take. The source and target servers are both on Windows Server 2008 R2 Standard. I using a single domain account to run the sql server and sql server agent services on both source and target servers and at any given point of time I have either the source or target up and running. The failover and failback works fine without any issue fulfilling our needs. But I am having an issue with the sql agent jobs after performing a failover or a failback. None of the sql agent jobs run. They fail with the following error:

'Login failed for user 'username'. The user is not associated with a trusted SQL Server connection. (Microsoft SQL Server, Error: 18452)'

However when I break the double take mirror and run the jobs on individual servers using the same account they run fine with out any issue. I have contacted double take and they said this is a bug from Microsoft which I am not sure of. Can someone kindly help me fix this issue.

Please let me know if you need additional details. Thanks a ton in advance.


“If your actions inspire others to dream more, learn more, do more and become more, you are a leader.” -- John Quincy Adams
Post #1364766
Posted Wednesday, September 26, 2012 12:35 PM
Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Friday, July 25, 2014 10:27 AM
Points: 1,319, Visits: 1,720
Experts I need your valuable inputs. Thanks Again.

“If your actions inspire others to dream more, learn more, do more and become more, you are a leader.” -- John Quincy Adams
Post #1364884
Posted Wednesday, September 26, 2012 1:33 PM
Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Friday, July 25, 2014 10:27 AM
Points: 1,319, Visits: 1,720
I verified my local policy settings and found out that "Enable computer and user accounts to be trusted for delegation" has none added to this policy. I just added the SQL Server Service Account and the Administrators group to it. I will keep posted if it works fine.

Still waiting for the experts thoughts/inputs.

Thanks


“If your actions inspire others to dream more, learn more, do more and become more, you are a leader.” -- John Quincy Adams
Post #1364909
Posted Thursday, September 27, 2012 12:41 PM
Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Friday, July 25, 2014 10:27 AM
Points: 1,319, Visits: 1,720
Sapen (9/26/2012)
I verified my local policy settings and found out that "Enable computer and user accounts to be trusted for delegation" has none added to this policy. I just added the SQL Server Service Account and the Administrators group to it. I will keep posted if it works fine.


Thanks


That is the fix. Adding the sql server service account to the "Enable computer and user accounts to be trusted for delegation" policy and sql services restart fixed the issue.


“If your actions inspire others to dream more, learn more, do more and become more, you are a leader.” -- John Quincy Adams
Post #1365449
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse