Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase 1234»»»

Cannot connect to SQL Server 2008 R2 remotely Expand / Collapse
Author
Message
Posted Thursday, July 26, 2012 7:37 AM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Thursday, August 21, 2014 4:53 PM
Points: 15, Visits: 43
I've attempting to create a Development box that host a SQL Server 2008 R2; however, I'm unable to connect to it remotely. I can't create an ODBC connection as well.

My setup is this:
Windows Server 2008 R2 Standard 64-bit

Sql Server 2008 R2:
Microsoft SQL Server Management Studio 10.0.1600.22 ((SQL_PreRelease).080709-1414 )
Microsoft Analysis Services Client Tools 2007.0100.1600.022 ((SQL_PreRelease).080709-1414 )
Microsoft Data Access Components (MDAC) 6.1.7601.17514 (win7sp1_rtm.101119-1850)
Microsoft MSXML 3.0 6.0
Microsoft .NET Framework 2.0.50727.5456

I’ve installed SQL Server 2008 on the machine and did the following:

1. I went to the server properties in Microsoft SQL Server Management Studio and checked the "Allow remote connections to this server" under Connections section.
2. I also went to SQL Server Configuration Manager and under SQL Server Network Configuration I enabled the TCP/IP Protocol.
3. Then went to Windows Firewall with Advanced Security and created an inbound rule for the Database Engine to allow connection for port 1433.

I would imagine that doing all of this would grant me access remote access to the box and create ODBC connections but this is not the case.

I have the error message attached to the this email.
Is there something I’m forgetting to enable? Setup?


  Post Attachments 
sqlserError.jpg (21 views, 39.93 KB)
sqlserError1.jpg (19 views, 47.09 KB)
Post #1335842
Posted Thursday, July 26, 2012 2:09 PM


SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Monday, September 15, 2014 5:39 AM
Points: 2,694, Visits: 3,387
Did you make sure the proper services are running; i.e. SQL Server and SQL Server Browser?

Thanks,

Jared
SQL Know-It-All

How to post data/code on a forum to get the best help - Jeff Moden
Post #1336113
Posted Thursday, July 26, 2012 2:17 PM
SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: 2 days ago @ 9:11 AM
Points: 417, Visits: 2,555
I have the error message attached to the this email.

Did you forget to attach the error message? I cannot find it.

Regards,
TA


Regards,
SQLisAwe5oMe.
Post #1336118
Posted Thursday, July 26, 2012 3:52 PM


SSC Eights!

SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!

Group: General Forum Members
Last Login: 2 days ago @ 5:16 AM
Points: 887, Visits: 1,774
have you configured the windows firewall to allow SQL Server traffic? I have had that issue my self.

http://msdn.microsoft.com/en-us/library/ms175043.aspx



For faster help in answering any problems Please read How to post data/code on a forum to get the best help - Jeff Moden for the best way to ask your question.

For performance Issues see how we like them posted here: How to Post Performance Problems - Gail Shaw

Need to Split some strings? Jeff Moden's DelimitedSplit8K
Jeff Moden's Cross tab and Pivots Part 1
Jeff Moden's Cross tab and Pivots Part 2

Jeremy Oursler
Post #1336166
Posted Thursday, July 26, 2012 3:59 PM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Thursday, August 21, 2014 4:53 PM
Points: 15, Visits: 43
I've attached the error messages sorry about that.
The inbound firewall rules were added already.
All service running has also been confirmed.
Same results.
Post #1336167
Posted Tuesday, July 31, 2012 1:14 AM
SSC Veteran

SSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC Veteran

Group: General Forum Members
Last Login: Friday, September 5, 2014 7:24 AM
Points: 209, Visits: 571
I have seen your attached error snapshot and have assumed two possiblities:

1. TCP\IP Services seems to be disabled. Which is not allowing you to handshake with remote server.
2. Please type correct Server\instance name.


Thanks,

Jitendra

Post #1337702
Posted Tuesday, July 31, 2012 7:10 AM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Thursday, August 21, 2014 4:53 PM
Points: 15, Visits: 43
Thanks Jitendra.

1. TCP\IP Services seems to be disabled. Which is not allowing you to handshake with remote server.

Where would I go to enable the TCP\IP service?

2. Please type correct Server\instance name.

I have confirmed that the Server\instance name is correct; therefore, this is not an issue.
Post #1337879
Posted Tuesday, July 31, 2012 7:19 AM


SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Monday, September 15, 2014 5:39 AM
Points: 2,694, Visits: 3,387
emmanuel.constant (7/31/2012)
Thanks Jitendra.

1. TCP\IP Services seems to be disabled. Which is not allowing you to handshake with remote server.

Where would I go to enable the TCP\IP service?

2. Please type correct Server\instance name.

I have confirmed that the Server\instance name is correct; therefore, this is not an issue.
SQL Server Configuration Manager is where you will go to check tcp/ip settings. his will be under the SQL Server Network Configuration. Go to Protocols for MSSQLSERVER (or your named instance) and make sure tcp/ip is enabled.


Thanks,

Jared
SQL Know-It-All

How to post data/code on a forum to get the best help - Jeff Moden
Post #1337889
Posted Tuesday, July 31, 2012 8:28 AM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Thursday, August 21, 2014 4:53 PM
Points: 15, Visits: 43
Thanks Jared.

Well then that has been addressed also. I made sure that was enabled as well.

I did discover that I have the Win2008 server which host the SQL Server 2008 on one domain and I'm attempting to access it from a client PC from another domain. Not sure if it matters or not; however, i reckon there should be a handshaking between the two domain security wise before the exchange of packet happen no?
Post #1337941
Posted Tuesday, July 31, 2012 9:19 AM


SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Monday, September 15, 2014 5:39 AM
Points: 2,694, Visits: 3,387
If you are attempting to use windows authentication, I don't think it will work that way. They must both be on the same domain.

Thanks,

Jared
SQL Know-It-All

How to post data/code on a forum to get the best help - Jeff Moden
Post #1337975
« Prev Topic | Next Topic »

Add to briefcase 1234»»»

Permissions Expand / Collapse