Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

The request failed with HTTP status 401: Unauthorized Expand / Collapse
Author
Message
Posted Monday, June 4, 2012 10:41 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Yesterday @ 11:53 PM
Points: 110, Visits: 649
Hi,

Server Error in '/xyz.aspx' Application.
--------------------------------------------------------------------------------

The request failed with HTTP status 401: Unauthorized.


Exception Details: System.Net.WebException: The request failed with HTTP status 401: Unauthorized.


Line 124: parameters.Add(new Microsoft.Reporting.WebForms.ReportParameter("utype", UserType.ToString()));
Line 125: Response.Write(parameters.Count);
Line 126: ReportViewer1.ServerReport.SetParameters(parameters);
Line 127: Response.Write("test" + parameters.Count);
Line 128: ReportViewer1.ProcessingMode = ProcessingMode.Remote;

Above error is triggering while generating from Web server.

web server with IIS 6.0 and ASP.net frame 2.0
Database on other server.
Reports on other Server.
Application is working fine
I can access reports from application with out deploying on IIS Server
After deploying on IIS when i am accessing Reports from application getting above error .

I can access reports
via Reportmanager/Report server.
but through application that to after deploying on IIS this problem persists.

In Report Manager access was given to following users
BUILTIN\Administrators Content Manager
BUILTIN\Users Content Manager
NT AUTHORITY\ANONYMOUS LOGON Content Manager
NT AUTHORITY\NETWORK SERVICE Content Manager
Domain\Administrator Content Manager
Domain\ASPNET Content Manager
Domain\USER(SSRS Serivce) Content Manager
Domain\Reprotserver$(system) Content Manager
Domain\WEBSERVER$(system) Content Manager

On web server
IIS
enable anonymous User ticked
systemname\IUSR_systemname.

Please do the needful to overcome the above issue...

Awaiting for your valuable replies...

Post #1310937
Posted Wednesday, October 31, 2012 2:40 PM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Monday, December 8, 2014 9:34 AM
Points: 45, Visits: 204
How did you resolve this issue? I'm having a similar problem. Was able to access reports fine until we added a certificate and started to use SSL etc. How it is failing the request with status 401.
Post #1379531
Posted Friday, November 2, 2012 8:11 AM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Monday, December 8, 2014 9:34 AM
Points: 45, Visits: 204
I found a fix for our issue in disabling loopback checking via modification of the registry.
Post #1380394
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse