Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

SQLServer2008 R2 BPA Expand / Collapse
Author
Message
Posted Thursday, May 10, 2012 2:55 AM
SSC Veteran

SSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC Veteran

Group: General Forum Members
Last Login: Wednesday, March 19, 2014 6:30 AM
Points: 250, Visits: 743
Hi All,

I'm not able to install SQLServer2008 R2 BPA.

ERROR

Log Name: Application
Source: MsiInstaller
Event ID: 11722
Task Category: None
Level: Error
Keywords: Classic
User: <Username>
Computer: <Machine name>
Description:
Product: Microsoft SQL Server 2008 R2 BPA -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action EnablePSRemoting, location: powershell.exe, command: -NoLogo -NoProfile -Command Enable-PSRemoting -force


Solution:

Open a command prompt with Administrative Privileges
Change to the directory where the .msi file resides
Type msiexec /i <MSI Name> SKIPCA=1
MSI Name will either be SQL2008R2BPA_Setup32.msi or SQL2008R2BPA_Setup64.msi depending on your platform
Once BPA is installed, open a PowerShell prompt with Administrative Privileges
Execute the following commands
Enable-PSRemoting
winrm set winrm/config/winrs `@`{MaxShellsPerUser=`"10`"`}

I have tried the above solution but still not able to install.

Please advice.

Thanks and Regards,
Ravi.
Post #1297692
Posted Tuesday, January 15, 2013 10:06 AM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Thursday, August 14, 2014 9:10 AM
Points: 11, Visits: 215
I realize this is an old thread, but I just had this error. The cause was the powershell part failing to run because I had a NIC set to public connection type.

The powershell error was:
Set-WSManQuickConfig : WinRM firewall exception will not work since one of the network connection types on this machine
is set to Public. Change the network connection type to either Domain or Private and try again.
Post #1407357
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse