Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Reporting servcie stopped working and throw dump file Expand / Collapse
Author
Message
Posted Monday, April 23, 2012 3:22 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Tuesday, August 19, 2014 9:21 PM
Points: 125, Visits: 1,061
Last Friday,we have one SQL Server 2005 reporting stopped to work. When access the reporting web site, we see following error:

"The server failed to resume the transcation. Desc:37000000280. The transcation active in this session has been committed or aborted by another session. "

From reporting error log, i found following error:

"w3wp!library!8!4/13/2012-13:46:16:: e ERROR: Throwing Microsoft.ReportingServices.Diagnostics.Utilities.InternalCatalogException: An internal error occurred on the report server. See the error log for more details., ;
Info: Microsoft.ReportingServices.Diagnostics.Utilities.InternalCatalogException: An internal error occurred on the report server. See the error log for more details. ---> System.Configuration.ConfigurationErrorsException: An error occurred executing the configuration section handler for system.web/identity. ---> System.Configuration.ConfigurationErrorsException: Could not create Windows user token from the credentials specified in the config file. Error from the operating system 'The parameter is incorrect.
' (C:\Program Files\Microsoft SQL Server\MSSQL.2\Reporting Services\ReportServer\web.config line 25
)"

And also i found mini dump generated, with a simple anaysis, i found following information:

STACK_TEXT:
219bf530 1d4a0e95 000042ac 00000000 00000000 kernel32!RaiseException+0x53
219bf57c 47415253 25cfefd0 6ca6bec1 79e71998 ReportingServicesNativeClient_1d480000!CDmpDump::Dump+0x95
219bf6b4 68685e47 06700994 06700994 51b123c0 ReportingServicesNativeClient_ni!_load_config_used+0x1983
219bf6d4 68685e47 026d8e5c 068631b8 0686354c System_Web_ni+0xc5e47
219bf70c 686883cf 00000001 219bf76c 48639754 System_Web_ni+0xc5e47
219bf724 6865a409 06700994 0686cf88 068638a4 System_Web_ni+0xc83cf
219bf76c 6865912d 219bf7bc 486318c4 06700c98 System_Web_ni+0x9a409
219bf780 6865e0bd 48639754 0a6e2cb0 0686ccc4 System_Web_ni+0x9912d
219bf7bc 6865dd72 0a6de5b8 486318c4 6865c447 System_Web_ni+0x9e0bd
219bf7f0 79f1ef33 00000000 010a1840 0671b584 System_Web_ni+0x9dd72
219bf8a8 79f1ed6a 1f08ac08 219bfac0 219bfb28 mscorwks!COMToCLRWorkerBody+0x208
219bf904 79f3b836 1f08ac08 219bfac0 219bfb28 mscorwks!COMToCLRWorkerDebuggerWrapper+0x37
219bfae8 01dba295 1f08ac08 219bfb28 6ca6bec1 mscorwks!COMToCLRWorker+0x4ba
WARNING: Frame IP not in any known module. Following frames may be wrong.
219bfb10 6a2bfbe3 219bfb60 01bb7e30 00000000 0x1dba295
219bfe70 6a2bfda8 1f1e5e10 00040000 6a2d91a5 webengine!HttpCompletion::ProcessRequestInManagedCode+0x1a3
219bfe7c 6a2d91a5 01bb7e30 00000000 00000000 webengine!HttpCompletion::ProcessCompletion+0x3e
219bfe90 7a110f08 01bb7e30 77e619d1 7a38e228 webengine!CorThreadPoolWorkitemCallback+0x18
219bfea8 7a112328 1f1e5e10 ef71d10a 00000000 mscorwks!ThreadpoolMgr::ExecuteWorkRequest+0x40
219bff14 79ecb00b 00000000 00000003 ffffffff mscorwks!ThreadpoolMgr::WorkerThreadStart+0x1f2
219bffb8 77e64829 1bd1db90 00000000 00000000 mscorwks!Thread::intermediateThreadProc+0x49
219bffec 00000000 79ecafc5 1bd1db90 00000000 kernel32!BaseThreadStart+0x34


FOLLOWUP_IP:
ReportingServicesNativeClient_ni!_load_config_used+1983
47415253 c6460801 mov byte ptr [esi+8],1

SYMBOL_STACK_INDEX: 2

SYMBOL_NAME: reportingservicesnativeclient_ni!_load_config_used+1983

FOLLOWUP_NAME: MachineOwner

MODULE_NAME: ReportingServicesNativeClient_ni

IMAGE_NAME: ReportingServicesNativeClient.ni.dll

DEBUG_FLR_IMAGE_TIMESTAMP: 4e2134f1

STACK_COMMAND: ~26s; .ecxr ; kb

FAILURE_BUCKET_ID: WRONG_SYMBOLS_42ac_ReportingServicesNativeClient.ni.dll!_load_config_used

BUCKET_ID: APPLICATION_FAULT_WRONG_SYMBOLS_reportingservicesnativeclient_ni!_load_config_used+1983

It seems ReportingServicesNativeClient.ni.dll caused this problem, but i don't know why. Has anybody encontered such problem? Thanks!




[li][/li]
Post #1288007
Posted Monday, April 23, 2012 11:31 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Tuesday, August 19, 2014 9:21 PM
Points: 125, Visits: 1,061
Add more infomation:

web config file line 25 <identity impersonate="true" />


[li][/li]
Post #1288652
Posted Thursday, May 3, 2012 11:30 AM
SSC Veteran

SSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC Veteran

Group: General Forum Members
Last Login: Wednesday, February 20, 2013 2:23 PM
Points: 254, Visits: 131
DBA328 (4/23/2012)
Add more infomation:

web config file line 25 <identity impersonate="true" />


What have you tried? Have you restarted the server?


Thanks,

David Russell
Oracle Since 1982
SQL Server Since 1998
Post #1294832
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse