Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase 12»»

Landscape vs Portrait printout Expand / Collapse
Author
Message
Posted Wednesday, April 21, 2004 1:02 PM
SSC Journeyman

SSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC Journeyman

Group: General Forum Members
Last Login: Monday, September 10, 2007 2:41 PM
Points: 87, Visits: 1

How do you tell it you want it to print landscape?  I have set the format of the report to 8/5 x 14, but when I try to print within the VS ide it prints portrait and, of course, only half the page. I try to export to PDF and again it is portrait. My report has so many columns that I need to do it in landscape. How is this accomplished????




Post #112408
Posted Wednesday, April 21, 2004 1:39 PM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Monday, October 14, 2013 1:28 PM
Points: 21, Visits: 17

Can you adjust your orientation in print setup? For example, your pdf-exported version gets loaded with Adobe Reader. If you go to File, Print Setup and choose Landcape orientation, doesn't it print landscape?

Semi-unfortunately, it seems that rendering and printing features have been completely separated. I would think that Adobe Reader would default the orientation to landscape if the page size was 11 x 8.5, but then that would be logical and not all programs operate that way.

Post #112413
Posted Wednesday, April 21, 2004 1:47 PM
SSC Journeyman

SSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC Journeyman

Group: General Forum Members
Last Login: Monday, September 10, 2007 2:41 PM
Points: 87, Visits: 1
yes, it prints landscape, unfortunately the report was exported in portrait, therefore it does me no good. In other words, only half the columns appear per page and there are twice as many pages as there should be, since it continues the other half on another page.


Post #112416
Posted Wednesday, April 21, 2004 2:00 PM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Monday, October 14, 2013 1:28 PM
Points: 21, Visits: 17

Sorry, I don't see that problem here. When I set my page size to 11 wide by 8.5 long, it exports as a landscape document in PDF. I did find the following note at http://sqljunkies.com/WebLog/ktegels/articles/1526.aspx, which may help explain the issue you're seeing:

"When attempting to export a report in landscape format to Adobe Acrobat Printer your default printer must support landscape mode.

"While researching the capabilities of SQL Reporting Services my default printer was set to "Microsoft Office Document Image Writer" which only supports portrait. Every time I extracted to Adobe, my reports were saved as portrait. After I changed the default printer to a driver that supported landscape mode I was able to extract the report to Adobe in landscape mode."

Check to make sure your default printer supports landscape mode.

Post #112417
Posted Wednesday, April 21, 2004 2:29 PM
SSC Journeyman

SSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC Journeyman

Group: General Forum Members
Last Login: Monday, September 10, 2007 2:41 PM
Points: 87, Visits: 1
I set my printer preferences to landscape and that seemed to work. Thanks


Post #112420
Posted Friday, May 07, 2004 8:40 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Wednesday, January 12, 2005 10:52 AM
Points: 1, Visits: 1
My default printer supports landscape, but still exports pdf in portrait.   Any suggestions?


Post #115038
Posted Monday, May 10, 2004 6:21 AM
SSC Journeyman

SSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC Journeyman

Group: General Forum Members
Last Login: Monday, September 10, 2007 2:41 PM
Points: 87, Visits: 1
Are you setting the page size to 11 x 8.5 in the lay out options for the report. Also make sure that you are not overflowing the margins. I found that you need to look at the properties of size for the body,report, and headers in the report. They were set too wide on mine and causing some margin overflows.  I have also found that the page sizes are not translating to the printer. Even thought the print preview shows landscape, when I go to print, I have to change the printer properties to landscape.


Post #115116
Posted Thursday, May 13, 2004 1:18 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Tuesday, February 22, 2005 3:23 AM
Points: 100, Visits: 1

Hi,

I have had this problem too.

In the end I used a browser control and set the printer options before rendering the report to the control.

 

Jamie




Post #115719
Posted Thursday, May 13, 2004 7:34 AM
SSC Journeyman

SSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC JourneymanSSC Journeyman

Group: General Forum Members
Last Login: Monday, September 10, 2007 2:41 PM
Points: 87, Visits: 1
Okay, guess it's because I don't have any training on this, but how do you set the printer options programmatically before rendering.  I simply have created a report project and don't see any where to do that.


Post #115799
Posted Wednesday, June 06, 2007 9:09 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Wednesday, June 06, 2007 12:22 PM
Points: 1, Visits: 1

Hi,

I am trying to print a report on legal size paper (landscape). When I run the report from IE, it seems to make it landscape but does not automatically select legal paper. Is there a way to change it for that specific report, so that when I use the print option in report manager, it automatically selects legal?

 

Any suggestion would be highly appreciated!

 

Regards,

F.A.

Post #371688
« Prev Topic | Next Topic »

Add to briefcase 12»»

Permissions Expand / Collapse